The incident has been resolved following the deployment of infrastructure improvements and additional monitoring. We have confirmed that email delays experienced by clients have significantly decreased, and services are now operating as expected.
Posted Nov 25, 2024 - 16:13 UTC
Monitoring
We released infrastructure modifications on November 12, and we are seeing substantial improvements in email delays. We are continuing to monitor to ensure smooth operation.
Posted Nov 20, 2024 - 18:48 UTC
Investigating
We are aware of an issue where CampusGroups Emails are being sent with significant delays in the US region. Recent improvements were made however, users with high traffic may experience delays of 15 to 30 minutes for message and notification delivery. Our team is actively investigating the cause of this disruption and working to fully resolve the issue as quickly as possible.
We understand the impact this may have on communication, and we will provide updates as soon as more information becomes available.