Issues with Event Registration Payment Processing and Platform Stability

Incident Report for CampusGroups

Resolved

After monitoring the system for the last 12 hours, the Engineering team can confirm that the system is working as expected.
Posted Mar 25, 2025 - 12:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2025 - 21:45 UTC

Update

We have identified and addressed the initial root cause; however, a secondary issue has emerged, preventing full platform stabilization. Our team is actively investigating this new problem and working to restore complete functionality as soon as possible. We understand the urgency of this situation and continue to treat it as our top priority.
Posted Mar 24, 2025 - 21:19 UTC

Identified

Users across multiple campuses have been unable to proceed to the payment page after registering for an event. This issue has affected various payment gateways.

We have identified the root cause and are currently deploying a fix. During this deployment, there may be temporary platform instability. We are closely monitoring the process to minimize disruption.
Posted Mar 24, 2025 - 20:09 UTC