We can now confirm the queue is empty and all notifications have been sent.
Posted Nov 26, 2024 - 17:45 UTC
Monitoring
We are monitoring the queue and notifications are currently being sent as expected.
Posted Nov 26, 2024 - 17:41 UTC
Investigating
We deployed an infrastructure change in the US region on November 19. We determined that over the past 5 days approximately 5% of these notifications were not delivered. These are being resent now, and should be received in the next few hours.